Author Topic: Did I have the 7th faulty Surface Pro 7?  (Read 1102 times)

0 Members and 1 Guest are viewing this topic.

Offline blueskullTopic starter

  • Supporter
  • ****
  • !
  • Posts: 367
  • Country: cn
  • BA7LKP
Did I have the 7th faulty Surface Pro 7?
« on: January 18, 2020, 01:16:40 pm »
If you've been following my previous posts on bad pixel rants and weird memory issue rants, you might know that I bought a SP7 on launch, then replaced it over and over again in search of one without bad pixels and memory instabilities.

Well, the 7th unit I got is starting to show memory issues.

On the last unit, the device constantly BSOD when I assign an SD card with a drive letter other than default one, and it is highly repeatable.

On this unit, it suffers from video stuttering, random lags and other graphic-related bugs that are not seen before on other laptops models.

Just like the previous one, Windows memory diagnosis tool reports no issue with default settings, and with cache-off settings, even basic test can't be passed. To be precise, it gets stuck there forever.

Question I want to ask is, is there anyone who has an SP7 or any Ice Lake based laptop and are there any weird things happening? I tried Googling, with no yield.

I think I might have just written off $1400 since MSFT China does not honor global warranty, just like any other Western brands here.

And since the instability issue is not reliably reproducible, I don't think even MSFT USA will honor the warranty. The previous returns were done at BestBuy before return periods.

So, did I just throw away $1400? It doesn't crash, though. I never had a SIGSEGV or BSOD, just video glitches, small but noticeable ones, everyday.
 

Offline LeonR

  • Regular Contributor
  • *
  • Posts: 156
  • Country: br
  • PC hardware enthusiast
Re: Did I have the 7th faulty Surface Pro 7?
« Reply #1 on: January 18, 2020, 05:35:36 pm »
E-mail their support with the full story and ask for a refund. Go for a different solution.
 

Offline wraper

  • Supporter
  • ****
  • Posts: 16863
  • Country: lv
Re: Did I have the 7th faulty Surface Pro 7?
« Reply #2 on: January 18, 2020, 05:43:43 pm »
Did you update firmware just in case?
 

Offline Ampera

  • Super Contributor
  • ***
  • Posts: 2578
  • Country: us
    • Ampera's Forums
Re: Did I have the 7th faulty Surface Pro 7?
« Reply #3 on: January 19, 2020, 05:42:56 pm »
I own a Surface Pro 3, and under Windows 10, I get similar video artifacts when playing YouTube videos.

It currently runs Linux, and it does not do that under Linux. All I can say to that is it's probably Windows, not the hardware.
I forget who I am sometimes, but then I remember that it's probably not worth remembering.
EEVBlog IRC Admin - Join us on irc.austnet.org #eevblog
 
The following users thanked this post: blueskull

Offline LeonR

  • Regular Contributor
  • *
  • Posts: 156
  • Country: br
  • PC hardware enthusiast
Re: Did I have the 7th faulty Surface Pro 7?
« Reply #4 on: January 21, 2020, 02:49:12 am »
Bummer. Can't you ship it to a HK or other nearby country with support?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf