Author Topic: Lady Heather v6 Beta for Windows .exe  (Read 32438 times)

0 Members and 1 Guest are viewing this topic.

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #25 on: July 02, 2018, 03:14:52 am »
If you downloaded the v6.05 .exe before 2 Jul 2018 and are using Jupiter/Zodiac receivers please download it again.   I fixed an issue that could crash the program... it's been in there for quite a while so I assume not many people use those receivers.
 

Offline metrologist

  • Super Contributor
  • ***
  • Posts: 1811
  • Country: 00
Re: Lady Heather v6 Beta for Windows .exe
« Reply #26 on: July 09, 2018, 03:39:33 pm »
I have one of those receivers so should give it a shot. Thanks for the continued efforts  :-+
 

Offline peteruk

  • Newbie
  • Posts: 2
  • Country: gb
Re: Lady Heather v6 Beta for Windows .exe
« Reply #27 on: July 13, 2018, 02:31:41 pm »
I've downloaded v6.05 (latest), but get a com error: 'COM: None'.  Used the same cfg file as with vers5, manual gives same result.  Any pointers?
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #28 on: July 13, 2018, 04:01:46 pm »
Make sure no other programs are using the com port.   Also, maybe re-boot the system...  some com drivers are known to not properly free the serial port when a program shuts down.
 

Offline peteruk

  • Newbie
  • Posts: 2
  • Country: gb
Re: Lady Heather v6 Beta for Windows .exe
« Reply #29 on: July 13, 2018, 05:16:20 pm »
Thanks for getting back.   I have checked for com port release, etc. Is it a 64 bit problem?  The version I'm running is Windows 10 Pro, 64 bit version 1803 build 17134.165.  There has never been any problem with previous versions of Lady Heather, but with vers 6.05 I don't seem to be able to open a com port, even /0 fails.  With vers 5 I can switch between various serial port monitors and Heather without errors.  Reason for 6.05 is to check out a True Position board.
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #30 on: July 13, 2018, 05:36:47 pm »
There are lots of people running it on Win-10 wihout any problems.   Also, the com port code has not changed since v3.0   I have no idea what's going on.   

/0 says to not use the com port, so that is expected to not work.
 

Offline metrologist

  • Super Contributor
  • ***
  • Posts: 1811
  • Country: 00
Re: Lady Heather v6 Beta for Windows .exe
« Reply #31 on: July 13, 2018, 08:27:10 pm »
w32sal.dll is missing on install.

3rd google hit:

https://github.com/elfchief/ladyheather/blob/master/heather.iss
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #32 on: July 14, 2018, 12:25:14 am »
w32sal.dll is missing on install.

3rd google hit:

https://github.com/elfchief/ladyheather/blob/master/heather.iss

Read the BOLD FACED text in the second paragraph of the first post in this thread...
 

Offline mark03

  • Frequent Contributor
  • **
  • Posts: 613
  • Country: us
Re: Lady Heather v6 Beta for Windows .exe
« Reply #33 on: July 16, 2018, 04:43:18 pm »
Lady Heather v6.05 defaults to three plots for my trueposition GPSDO:  temperature, # of satellites, and EVAL.  What is EVAL?  It's a dimensionless quantity, so no hints.  The LH manual doesn't mention it.  (Plot type 8 was reserved for future use, so maybe this is new in the beta?)

I'm also wondering if there is a way to tell which features of the program are supported on a given device.  E.g. when I try to plot PPS or OSC data, I get a flat line, so, presumably not supported?
 

Offline richnormand

  • Supporter
  • ****
  • Posts: 382
  • Country: ca
Re: Lady Heather v6 Beta for Windows .exe
« Reply #34 on: July 24, 2018, 09:44:07 pm »
Just to add thanks to texaspyro for the new version of Lady Heather.

I have upgraded with your instructions in the original post and it works great on a dedicated Dell laptop running XP.

I have a unit that is recognized as a UCCM receiver (Trimble) and it outputs a 2 second signal on the RS232.
As you mentioned, way back, you did implement a 1 sec interpolation that does make the interface much more "intuitive" now.

Thanks and keep up the good work.
Cheers  :)

 

Offline PA0KTF

  • Contributor
  • Posts: 18
  • Country: nl
Re: Lady Heather v6 Beta for Windows .exe
« Reply #35 on: July 28, 2018, 04:26:00 pm »
I have the GPSDO as seen here. It is similar to a Trimble board, but with Ublox LEA-6T receiver and Samsung TCXO.
It locks to GPS, frequency output ok.
Via RS232 connected to LH. Via /rx connection made: 57600:8:N:1.
Satellites detected, but error message "NO DATA SEEN ON COM DEVICE" alternating with "UTC time ok Receiver data". See images.
It looks like LH cannot detect all data from this board.
How can I connect this board to LH ?
Or, if this board is not listed, can this board be added to LH ?
Thanks and keep up the good work.
« Last Edit: July 28, 2018, 04:37:50 pm by PA0KTF »
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #36 on: July 28, 2018, 06:57:21 pm »
These receivers don't automatically send most data so Heather must poll for each message and the process the response.  This happens once a second.   If the board does not respond to a message request, the the com port will time out and you get the "no data seen...",  then Heather restarts the polling loop.

It looks like the board does not support one of the messages being requested.   Try writing a debug file for a couple of minutes (WX keyboard command) and post the results.

Where did you get the board from?
 

Offline PA0KTF

  • Contributor
  • Posts: 18
  • Country: nl
Re: Lady Heather v6 Beta for Windows .exe
« Reply #37 on: July 29, 2018, 08:22:26 am »
texaspyro, thanks for the quick reply, here is the debug file.
I got the board from a source in China in Shenzhen via my family in law.
Thanks for looking into my problem.
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #38 on: July 30, 2018, 02:27:21 am »
Hmmm... still not sure what is going on.   It looks like the receiver may have some non-standard spacing issues with some of its' output messages.  Try creating a raw data capture file (WY keyboard command).  This will capture every byte that the device sends.
 

Offline PA0KTF

  • Contributor
  • Posts: 18
  • Country: nl
Re: Lady Heather v6 Beta for Windows .exe
« Reply #39 on: July 30, 2018, 08:17:35 am »
Here is the raw data file.
I hope you can make something out of this.
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #40 on: July 30, 2018, 07:07:12 pm »
Here is the raw data file.
I hope you can make something out of this.

Wow!  That's one messed up receiver.   It ends a lot of lines with 0x0D 0x0A 0x0D  which really confuses Heather.  All the other models use 0x0D 0x0A.   Also the formatting of the "UCCM >" prompt is different.
 

Offline metrologist

  • Super Contributor
  • ***
  • Posts: 1811
  • Country: 00
Re: Lady Heather v6 Beta for Windows .exe
« Reply #41 on: July 30, 2018, 07:17:22 pm »
That's a very early firmware, I  think newer than one of mine, which also does not seem to report all things properly.
 

Offline PA0KTF

  • Contributor
  • Posts: 18
  • Country: nl
Re: Lady Heather v6 Beta for Windows .exe
« Reply #42 on: July 30, 2018, 08:03:37 pm »
Here is the raw data file.
I hope you can make something out of this.

Wow!  That's one messed up receiver.   It ends a lot of lines with 0x0D 0x0A 0x0D  which really confuses Heather.  All the other models use 0x0D 0x0A.   Also the formatting of the "UCCM >" prompt is different.

Not the answer I wanted to hear.
This unit is from 2014, so I would think that the firmware would be the same or of later date than the Trimble units.
Is there a way to adapt LH for this unit type ? In the debug file I can see that the info is there.
« Last Edit: July 30, 2018, 08:06:54 pm by PA0KTF »
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #43 on: July 30, 2018, 09:31:29 pm »

Not the answer I wanted to hear.
This unit is from 2014, so I would think that the firmware would be the same or of later date than the Trimble units.
Is there a way to adapt LH for this unit type ? In the debug file I can see that the info is there.

The info may be there but it is in a format that Lady Heather does not understand.  I may be able to adapt it, but without a unit to test with I have no way of figuring out exactly what needs to be done or test the code.

Check your PM's...  I sent you a message.  If you can compile the code, we can probably work it out... sending Windows .EXE files is usually blocked by ISPs and email services.
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #44 on: August 01, 2018, 09:55:03 pm »
Updated the code attached to the first post to v6.08.   Main difference is added support for a couple of new devices and possibly fixed the program to work with the UCCM GPSDOs with the Ublox receiver and Samsung OCXO.
 
The following users thanked this post: PA0KTF

Offline BetoSaba

  • Newbie
  • Posts: 4
  • Country: br
Re: Lady Heather v6 Beta for Windows .exe
« Reply #45 on: August 06, 2018, 04:26:49 pm »
Hi!

If possible, I want the source code in order to compile for Linux/Raspberry Pi...
 

Offline linux_user

  • Newbie
  • Posts: 3
  • Country: us
Re: Lady Heather v6 Beta for Windows .exe
« Reply #46 on: October 06, 2018, 12:32:38 am »
I just sent a PM with my email address so I can get the V6 linux code.

Thanks!
 

Offline texaspyro

  • Super Contributor
  • ***
  • Posts: 1333
Re: Lady Heather v6 Beta for Windows .exe
« Reply #47 on: October 06, 2018, 03:20:52 am »
I'm in the middle of doing some edits... hopefully will be available next week.

I also apologize to the other people that have requested it... I've been out of town quite a bit this summer.
 

Offline linux_user

  • Newbie
  • Posts: 3
  • Country: us
Re: Lady Heather v6 Beta for Windows .exe
« Reply #48 on: October 07, 2018, 04:50:44 pm »
No problem  :-+  Thanks for all your hard work!
 

Offline frankmhowell

  • Contributor
  • Posts: 7
  • Country: us
Re: Lady Heather v6 Beta for Windows .exe
« Reply #49 on: October 29, 2018, 03:30:13 pm »
You might get a free Dropbox account if you don’t have one to stage the *.exe download. A lot of free software authors are going this route to deal with ISP blocks...

Frank
K4FMH
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf